Error when using an action rule to add a connection to a table

I have a page that’s been working fine for ages (and that I’d not tinkered with) but a few weeks ago it started generating this error…
image

I have dug into the logic in an action rule and the culprit appears to be this assignment, during the creation of a new connected record…

If I remove it, the error goes away, but the logic on my page breaks.

Strangely the value does appear to get set, but it seems to be causing the erroring in that action rule, causing rules below it not to fire.

As follows…

Before, with:-

  • three rows in the transactions table, and,
  • one row in the ReceiptBank Documents table, that I will trigger the action rule from - the ‘Adumo’ value - this is the connection that will be ‘copied’ across

After, with:-

  • four rows - 1 newly created - in the transactions table, and
  • the 4th row with the connection field set as intended, and
  • the error which causes further action rules not to fire, breaking the intended page logic.

Does anyone have any suggestions how to troubleshoot the cause?

Are you connecting the records in both directions? (child to parent and parent to child)

Thanks @Marty

No.

I am replicating an existing (working) connection from a row in one table, to a new row in a different table.

What’s puzzling me, it that it worked before…

If it helps, here’s a video of the issue…
https://brett.s3.filebase.com/Recording

Hi

Looking at this, the highlighted step in the action is a repeat of a step already made half way down the page. Is that intentional?

Hi @mtif

Many thanks for having a look at my problem.

I see it. WELL SPOTTED!
Yes, an error (introduced when I rebuilt that rule).

I have fixed that (see blow) but still get the error, though. :frowning:

(I’d love to be able to see the raw error log - that will make this so much easier to figure out).

I have fixed it from…

To…

Looking at this I wonder if you could try getting the ‘connected Value’ of the Supplier rather than Record Value. Would that work?

Thanks @mtif

The ‘connected values’ don’t include the join (or recordID) of the company, so I don’t see how this could work*. I’m replicating the join, not replicating a data value.

*But having said this, there may be a work around based on this thinking, if I expose the company’s recordID and set that in the join field. I’ll look at that as a plan B (as it does increase the complexity of something that worked before).

Many thanks for the assist @moe

The error was being caused by a pipe not firing correctly due to a missing variable value.

With the disabled, everything is working again.

1 Like