Stop double-click

I seem to have some users that are double-clickers. When they submit forms, I believe they are clicking twice which is causing some duplication when running my form rules. Any ideas on how to stop this??

“Anything that can go wrong, will go wrong”

I don’t have any experience with JavaScript, but I know you can disable the submit button after clicking with some JavaScript. Maybe @Chem can help?

Depending on your situation, you could also redirect somewhere after submitting the form.

Thanks Tim. I do have page redirects on the pages, but the duplicates still show up every now and then. Maybe I’m missing something else…

Some quick and easy options - (1) Put an HMTL note and the bottom of your form which will show right above the SUBMIT button - NOTICE: Only click SUBMIT Once - or something similar AND (2) Add a validation rule on the form that checks any field for UNIQUE ie NAME FIELD - once they click submit and the record is added then if they try to click it again they will get an error that NAME already exists which will prevent the duplication.


I’m still having this issue and can’t seem to resolve it. I can click submit about 5 or 6 times before the page closes and it will create that many entries.
You mentioned that maybe @Chem might have some magic java script?


Did you try any validation rules? I haven’t tested if they’d be fast enough to beat a double though.

I did, but they don’t stop it.