Cannot set up dependent dropdown! Feature broken?

I have watched the YouTube video on dependent dropdowns repeatedly. It’s clear and I believe I understand it completely. I was able to get the technique to work just one time, but now I can’t get it to work anywhere. I’ve rebuilt a new app from scratch three times and I’m still unable to make it work.

The essence of the problem is that I do not see the “Show” option for the field whose selection list I want to be dependent upon another connected value. Here’s a screenshot of the option I need, made from the YouTube video (here, at 1:20):

As I said, I have seen this option once before, so I know what I’m looking for; and of course it’s there in the YouTube video, as I just showed. But now no matter what I try, I can’t get it to appear.

Has this feature broken?

Click disclosure triangle for more info about what I've done....

My app has three tables that are pertinent here:

  1. Clients
  2. Projects
  3. Activity

The relationships are (I trust) fairly obvious but to be clear and explicit: I’ve connected Projects to Clients; and I’ve connected Activity both to Clients directly and to Projects (per the instructions in the video). When I edit the ConnectedProject on the New Activity Record form, I expect to see the Show option that will allow me to select “Projects connected to this form’s Clients”. But I don’t.

I even tried redoing the connections so that instead of Projects being connected to Clients, Clients are connected to Projects. But that doesn’t work either.

This is decisively important to me – and the YouTube video shows that this at least used to be possible. I’m desperate for somebody to throw me a clue here!

William

@WilliamPorter I think you’re onto a recent bug that got recently introduced. My apologies. We’ll have this fixed within a few hours.

@moe Thanks for the quick response and explanation. I understand – bugs happen. Glad to know I wasn’t going crazy. :slight_smile:

1 Like

HI William,

We’ve semi-fixed this issue. It does work now and will show up but only works if all the fields are on the first step of the form.

For example, the Car Makes and Car Models field must be on the first step of the form. Soon we’ll have a more permanent fix which will work across steps.

I apologize about the inconvenience this caused. This bug was intruduced with our new Multi Step feature. Apparently we didn’t test it enough. :man_facepalming:

Thanks Again

1 Like

THANKS, Moe. Yes, I had noticed the new steps feature.

Putting my dependent dropdown on the first step won’t be a problem, especially as I haven’t had a chance to try out a second step yet. :slight_smile:

Thanks again for the quick response.

William

Looks like it’s working again. And while I’m not 100% sure about this, but I think it might be working better than it did before it broke. I have this vague recollection that, before dependent dropdowns broke a couple of days ago, I had been able at least once to view, in a form for table T, a dropdown for connected table B that was dependent on table A – but that I had NOT been able to get a dropdown for table C that was dependent on B to work. Today I have managed to do just that, which is great. As I said, I might be wrong about how it worked or didn’t previously, but in any case, it’s working now very well.

Thanks for fixing this so quickly!

William

1 Like