Deactivate Browser Autofill

I’m looking for a way to deactivate the native browser autofill when entering addresses.
This is a problem for users who are adding lots of clients and the browser autofill is trying to complete and making the Tadabase google address lookup hard / impossible to see sometimes.

I’ve seen this as an option in another form builder, so I assume it’s a javascript of some sort.


This is something that also drives me crazy.

Are you referring to address fields auto getting filled in? or the pop up that shows autofill options?

Meaning, are the fields being populated without any user interaction? or is there a popup that shows up when they start entering an address?

If its the former, we can easily solve this with a new option in the fields:

I’m not sure if this will solve your requirements.

I’ll update this post here as soon as we’re live with this change (2-3 days). Or send me an email if you want to test it sooner.

1 Like

That’s the one! I can wait for this feature to roll out. Thanks @moe

@mdykstra this is now in production. Can you give this a shot and see if this fixed the browser autofill issues?

Does not seem to be working on the address component.
Mac / Chrome

Appears to be working on Safari

I tested it on the new Microsoft Edge and it isn’t working there either :frowning: