Duplicate Parent and Child

Hey guys, I am hoping someone has successfully duplicated a parent record along with it’s child records using the record utilities pipe on a DataTable and can let me know where i might be going wrong.

I have now been able to successfuly duplicate a record on a DataTable rule but not able to successfuly duplicate the child records.

I have set the values in the Pipe to the child table ID and the field ID of the connection field in the child table. Should these values be something different? I’ve exhausted all resources i could find without a solution.

@richardch372 -

Easy fix…for your parent table ID use the actual ID of the table (similar to the child table ID). Select “custom value” then enter the table ID.

The pipe will work then.


Thanks for the suggestion @SafetyUniversity i have tried it without success. Support are having a look at it for me.

Stupid question here but do you have a correct API key assigned to the Pipe?

Not so stupid Adam as orignally i hadn’t :grimacing:. The parent record is duplicating just fine. Its the child record which doesn’t.

I had the following response from TB which was very disappointing based on the hours invested in this.

@richardch372, I apologize about this message from our team.

The pipe does indeed work, we simply don’t offer support for it since its beyond the scope of standard support. It can get quite complex trying to get this working and is generally more of a implementation question vs support.

I sent you an email.

I have tested this API call and whilst I can confirm the Duplicate Parent and Child Pipe does work with a simple child table and record.

I too am also experiencing problems with using this on my real application, where the child record has a lot of fields, connections and rules running on it. In my live app only the parent record gets created. I’ll continue to troubleshoot and report the issue to support but I’m wondering if it’s timing out, has anyone else used this pipe with success?

[incidentally: the “field in the child table to use” does refer to the connection field in the format field_xxx as per @richardch372 screenshot above.

I’ve had a similar experience where only a portion of the child records are being duplicated. 47 out of 53 child records are actually being duplicated…however, in the very first parent record all of the child records are duplicated.

I have not had time to troubleshoot…

Anyone have any ideas?


1 Like

My suspicion is that it’s timing out (that might make sense why some of yours work and some don’t too) and we need to push equations to background queue but since I can’t change the header of the API call in this pipe I can’t experiment with that. I’ve opened a ticket and will update this post with any updates I might receive from support as it looks like at least two others are experiencing similar issues. :crossed_fingers:

We are using the duplication but need to check each one as we get random results. We run another rule straight after the duplication rule which is related to the duplication and that produces randon results as well.

1 Like

Hi Tadabase Community,

I got the same problem using the Duplicate Parent and Child under the Record Utilities Pipe.

I record the error and I hope someone can help me with it.

Thank you

@edison -

From what I can tell there is a cap on the number of “calls” per minute and then the pipe will automatically quite/fail.

This may help,

I’ll check on it.

Thank you so much in taking time for answering on this. I really appreciate it :slight_smile:

Hi @moe !

I am really frustrated on where I might be wrong, at first, its working, then later the parent is duplicated but the child record didn’t. Does that mean we cannot use the Duplicate parent and child call in the Record Utility Pipe anymore? I’ve been working on it for a couple of months.

The suggestion Make.com is only limited. Hope I someone can help me with this Duplicate Parent and child.

Thank you

UPDATE: Tadabase dev did update the API call so you can enable background equations when you make this call, but for me it didn’t fix the underlying issue that the Duplicate Child API call is unreliable (works on simple test tables but not on my production system)

That explains why it was working at the start.
Did you mean the duplicating of the child record was unsuccessful?
If so, did you find another way to copy those child records? I hope you can share it if it’s ok.

Thank you

1 Like

Hi @edison,

Ultimately I couldn’t get the pipe to work. If I built a new app and a very simple table with a Child record it worked but in my live app I have a lot of joins and equations going on so I suspect the complexity somehow breaks it (perhaps a time out, who knows).

I reluctantly built a solution in Make.com,


1 Like

Got it. Thank you very much for your reply.

1 Like