Getting Url of Image in two step form

Apologies upfront for double posting on this but as I added to my old post I noticed it hadn’t risen to the top. This is not working for me Creating a pipe to get the URL of image fields

Briefly, I am creating a prototype receipt scanning app using a tag gun pipe. I have a two-step form. In step one the user uploads the image and submits it then step 2 form opens. I have a record rule in step one that uses a pipe (as per the link above) to capture the URL of the scanned image to a text field so I can submit it to tag gun in step 2.

I CAN NOT get the pipe to pick up the URL of the Image. What I have tried so far:

  • I tried formatting the IMAGE URL field as a Link and also tried text. but neither helped.
  • I tested a simple record rule (no pipe) update the URL with the custom text “Hello World” and that worked.
  • I also tried a simpler text pipe that converted a comment from lower to uppercase and that DID work
  • I removed the 2nd step in the pipe - i.e. the action step that reformats URL but still did not pick up even a partial URL from the Image field.

Any advice on troubleshooting this would be greatly appreciated. I’m thinking because there is a TAGGUN pipe somebody must have cracked this use case somehow. :thinking:

Once I get this working I will write up a full description of the build
tks
Noel

In order to continue troubleshooting, as an alternative, I added a trigger pipe to step 2 of my form.

. I simplified the pipe to one step, for now, to see if it is picking up ANYTHING. When I click on the button that triggers the pipe is puts the word “False” in the target text field. That would indicate that the pipe is not doing what I expect which is to pick up the URL of the Image (even a malformed one without the action step). No clue where to go with this at this stage

Hey @arthurbuy

I can help with this!

What field are you using to hold your image? Is it the image field or the attachments field?

I’m using image field type

I tried (just now) using an attachment field type but got same “false” result tks

Hi @arthurbuy

Here’s a video to explain 3 methods of getting an Image URL and saving the value to a text field.

The responses mentioned in the video are as follows…

Get URL from Image Field: item.field_33.src
Get URL from Attachments Field: item.field_37.0.url

Remember to replace field_XX with your field_ID

Tadabase Rest API - Get a Single Record - Responses

Table Rule for Tadabase Text Utilities Pipe

Table Rule for REST API - Make sure to map correct response

Hi Tim, super response. Thank you so much for taking the time on this.
I will try this out and let you know how I get on
tks again
Noel

@tim.young Well after a lot of playing around and three days later on and off, I got method one above working (as per the original post).
I had originally copied the ensureLeft(‘https:’) from the linked post and pasted it in and always got an error.
Actually typing in ensureLeft(‘https:’) worked. The only difference is the proper use of single quote versus apostrophe :exploding_head: . This forum software seems to convert single quotes to apostrophe so I can see the difference now as a I type but on the preview window it has converted the single quote to apostrophe. 3 days later I figured this out and learned alot about API’s along the way. You go to just love computers :grimacing: :slightly_smiling_face: